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[ ] @] sample_project - RStudio

O -l%ml=- = =) Go to file/function " - Addins ~ R sample_project ~

4 sample_project.qmd e | Environment  History Connections Build Tutorial o ]
-l a RenderonSave ), (O ' up Render - a FRun ~ G - 2 [] "7 ImportDataset - ) 172MiB - List + | & ~
Source | Visual = Outline R ~ 7} Global Environment ~

1~ - Functions

2 title: "sample_project" set function (name, value) -J

-

A

5~ ## Quarto

6

7 Quarto enables you to weave together content and executable code into a
finished document. To learn more about Quarto see <https://quarto.org>.

8
9+ ir} >
12 1 +1
17~ %
12
Files Plots Packages Help Viewer Presentation P |
©|New Folder ' © NewBlank File ~ ' € Delete =|Rename = {3 More ~ ]
£} Home > Documents > courses > sample_project ®
A Name Size Modified
t.
o] _quarto.yml 388B Jan 16, 2024, 11:37 AM
% sample_project.qmd 206 B Jan 16, 2024, 11:37 AM
R sample_project.Rproj 2588 Jan 16, 2024, 11:37 AM
11 E3 sample_project + Quarto *
Console  Terminal Background Jobs P |

‘R R4.3.2 - ~/Documents/courses/sample_project/
Platform: aarché4-apple-darwin2@ (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale
R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.
Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.

Type 'q()' to quit R.

>

RStudio at startup with an empty sample project



# COVID

## Convenience functions
e utility}

get_data <- function(url){

## Get data from ECDC

“*{r get-data}
data_raw <- get_data(url)

#4 Clean it

Notes on the cleaning
process.

“**{r clean-data} CDVid'pr'Oject/

covid <- data_raw 2>%

mutate(.) %>%
select(.) B__

## Make some plots

**{r eda-plots}

figures/
casetrend

casetrend

RStudio schematic overview
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4 sample_project.qmd =0
& a [ JRenderonSave ')/ O apRender < - Lc IRET SRun ~ ‘G -
Source | Visual = Outline
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2 title: "sample_project"

o - -

4

5- ## Quarto

6

7 Quarto enables you to weave together content and executable code into a
finished document. To learn more about Quarto see <https://quarto.org>.

8

9- 7 qr} =
12 1 +1

17~ %

12

11 E3 sample_project + Quarto *

Console  Terminal Background Jobs P |
R R4.3.2 - ~/Documents/courses/sample_project/

Platform: aarché4-apple-darwin2@ (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale
R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.
Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.

Type 'q()' to quit R.

>

RStudio at startup

sample_project - RStudio

Environment  History Connections Build  Tutorial
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R ~ | {h Global Environment ~
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Viewer  Presentation
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Ol -lopla- & A Go to file/function - Addins -

£ sample_project.gmd

=0

Source  Visual = Outline

1+ |-
title: "sample_project"
34 -

#t Quarto

Quarto enables you to weave together content and executable code into a
finished document. To learn more about Quarto see <https://quarto.org>.

i
1+ 1

Paper, Analysis,
eport, Notes, efc:
a quarto file

1:1 E3 sample_project = Quarto *
Console  Terminal Background Jobs =0
‘R R4.3.2 . ~/Documents/courses/sample_project/

Platform: aarché4-apple-darwin2@ (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale
R is a collaborative project with many contributors.
Type 'contributors()' for more information and
‘citation()' on how to cite R or R packages in publications.
Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.

Type 'q()' to quit R.

>

sample_project - RStudio

& sample_project ~

Environment  History Connections Build  Tutorial ==
“# [} 7 Import Dataset - ) 172Mig -  § List ~ -
R - 7} Global Environment -
Functions
set function (name, value)
Files Plots Packages Help Viewer Presentation —=
© | New Folder  © New Blank File + © Delete - Rename {3 More -
£} Home - Documents - courses - sample_project R
A Name Size Modified
t.
@ _quarto.yml 388 Jan 16, 2024, 11:37 AM
#7 sample_project.qmd 206 B Jan 16, 2024, 11:37 AM
R sample_project.Rproj 2588 Jan 16, 2024, 11:37 AM

RStudio at startup



e -mlar- = A Go to file/function - Addins -
% sample_project.qmd =0
RenderonSave ' (i  =p Render - ] SRun - | G -
Source | Visual = Outline
1~ ==
2 title: "sample_project"
3  ——
4
5~ ## Quarto
6
7 Quarto enables you to weave together content and executable code into a
finished document. To learn more about Quarto see <https://quartoc.org>.
8
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Platform:
R is free software and comes with ABSOLUTELY NO WARRANTY.

You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale
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Type 'contributo
'citation()' on
Type 'demo()' fo
'help.start()' f
Type 'q()' to qu
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RStudio at startup




[ ] [ ] sample_project - RStudio

o - O - [} A Go to file/function ~ Addins - & sample_project -
% sample_project.qmd P | Environment  History Connections Build  Tutorial =
Render on Save = ',/ C  =p Render - b 'c] #Run ~ <5~ 2 || ‘7 ImportDataset v+ 3 172MiB - § List ~ -
Source | Visual = Outline R - 7k Global Environment -
=== Functions
2 title: "sample_project” set function (name, value)
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7 Quarto enables you to weave together content and executable code into a
finished document. To learn more about Quarto see <https://quarto.org>.
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Files Plots Packages Help Viewer Presentation
© | New Folder © NewBlankFile - © Delete =)Rename {3 More -

42 Home » Documents - courses - sample_project
A Name Modified

t .

@l _quarto.yml Jan 16, 2024, 11:37 AM
| sample_project.gmd Jan 16, 2024, 11:37 AM
% sample_project.Rproj Jan 16, 2024, 11:37 AM

11 B sample_project 3
Console  Terminal Background Jobs

(R R4.3.2 - ~/Documents/courses/sample_project/
Platform: aarché4-apple-darwin2@ (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale
R is a collaborative project with many contributors.

Type 'contributors()' for more information and
‘citation()' on how to cite R or R packages in publications.

Project files. Also has tabs
L for plots, help system

'help.start()' for an HTML browser interface to help.
Type 'g()' to quit R.

RStudio at startup
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11 E3 sample_project + Quarto =
Console Terminal Background Jobs =0

‘R R4.3.2 - ~/Documents/courses/sample_project/

Platform: aarché4-apple-darwin2@ (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
‘citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'g()' to quit R.

RStudio at startup
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Your code 1s what’s real in your project

Options

General

Code

> Console

'_J

Appearance
Pane Layout
Packages
@ R Markdown
e Python

@ sweave

aBc

v Spelling
W Gityswn
"3,- Publishing

- Terminal

G Accessibility

O Copilot

Basic | Graphics = Advanced

R Sessions

Default working directory (when not in a project):

~ Browse...

v|Restore most recently opened project at startup

+ Restore previously open source

Workspace UnChGCk

Restore .RData into workspace at startup:
Save workspace to .RData on exit: | Never |
History
+| Always save history (even when not saving .RData)
Remove duplicate entries in history
Other
v/ Wrap around when navigating to previous/next tab
v Automatically notify me of updates to RStudio

Send automated crash reports to Posit

OK Cancel

Apply

Tools > Global Options > General

Uncheck “Restore .RData into
workspace at startup”



onsider not showing output inline

Options
General
Code
> Console

T Appearance
Pane Layout
Packages

|

| @ R Markdown
F Python
@ sweave

ABC

7 Spelling

| @ cit/svN

f "5,- Publishing

- Terminal

0 Accessibility

L o Copilot

brrvear rons -

Basic Advanced Visual Citations

R Markdown
v|Soft-wrap R Markdown files ( U n C hec k

Show output inline for all R Markdown documents

Show output preview in: | Window v |
Show equation and image previews: | Inline v
Evaluate chunks in directory: | Document |

Document Outline

Show document outline by default

Show in document outline: | Sections Only v

Document outline font size: |9 |

R Notebooks
v Execute setup chunk automatically in notebooks

v Hide console automatically when executing notebook chunks

2 Using R Notebooks

OK Cancel

Tools > Global Options > RMarkdown

Uncheck “Show output inline for all R
Markdown documents”

Apply



Things an IDE brings together

A text editor for writing code and documents

A console or REPL (Read-Eval-Print Loop) for running code interactively
A terminal to talk to the operating system

A debugger to help find problems in your code

A file manager to navigate your project

A version control interface to manage changes to your code

A viewer for plots, tables, and other outputs

An inspector to see what’s in your environment



RStudio is just one IDE

Positron (a newer IDE for R and Python)

VS Code (a general-purpose IDE that supports many languages)
JupyterLab (an IDE for Python notebooks)

Text editors like Vim, Emacs, and Sublime Text can be configured to work like
IDEs, too.



An IDE 1s not required

You can write R code in any text editor and run it from the command line.

You can do the other things an IDE does with separate tools, via the command
line or other applications.

However, IDEs make your life easier.

They also don’t impose much structure on your projects. If you want to switch
to another, or to no IDE at all, you can do so without much trouble.



Fundamentally ...

A core set of interdependent tasks that require doing things with the
computer.

A modular set of tools that do specific things, built around a text editor, a
console, and plain-text configuration or code files.

Some method of organizing and orchestrating these tools.



Writing documents



Use Quarto to
produce and
reproduce your
work



Where we want to end up



Where we want to end up

Covid Cases

Kieran Healy

Introduction

We will look at some data from the covdata package.

cname cases

France 2376852
United Kingdom 1849403
United States 16256754

A little graph

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut
labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco
laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in
voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat
non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

PDF out
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HTML out

Where we want to en

Covid Cases

AUTHOR
Kieran Healy

Introduction

We will look at some data from the covdata package.

cname cases
France 2376852
United Kingdom 1849403
United States 16256754

A little graph

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore
et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut
aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse
cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa
qui officia deserunt mollit anim id est laborum.
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Where we want to end up

Daily COVID cases in 2020 for three countries
Covid Cases
Kieran Healy

Introduction 1e-03-

We will look at some data from the covdata package.
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United Kingdom 1849403
United States 16256754
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A little graph

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in
reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est ' ! ' '
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How to get there?

# COVID

# Get data from ECDC

# FIXME Write a fn to

# do this

data_raw < read_csv(url)

# Clean it

# Notes on the cleaning
# process.

covid « data_raw D
mutate(..) D
select (...)

# Make a plot
covid D
ggpplot(..) +
geom_line(..) D
ggsave ()

We could write an R script with some notes inside,
using it to create some figures and tables, paste them
into our paper, which we write separately.

This will work fine. In fact, the more complex our
projects get, the more likely it is we will write more
standalone code like this. It will also look less and less
like a single all-in-one-breath script and more like a
structured collection R files that combine to do many
things.

But to begin—and in fact for quite a long time after—
we can also do things a little differently, by taking a
more notebook-based approach. For many use-cases

this will be better.



We can make this...

1. Lorem Ipsum

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do

nisi ut aliquip ex ea commodo consequat.

Biscuits

Tea




# Lorem Ipsum

Lorem ipsum dolor sit amet, consectetur adipisicing elit,

library(ggplot2)

tea <- rnorm(100)

biscuits <- tea + rnorm(1600, 0, 1.3)

data <- data.frame(tea, biscuits)

p <- ggplot(data, aes(x = tea, y = biscuits)) +
geom_point() +
geom_smooth(method = "1m") +
labs(x = "Tea", y = "Biscuits") + theme_bw()

print(p)

Duis aute irure dolor in reprehenderit in voluptate velit esse
cillum dolore eu fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt in culpa qui officia
deserunt mollit anim id est laborum.



The gets replaced by its

This way of doing things is called a Literate Programming or Notebook approach.

# Lorem Ipsum

Lorem ipsum dolor sit amet, consectetur adipisicing elit,
sed do *ejusmod tempor* incididunt ut labore et dolore magna
aliqua. Ut enimad minim veniam, quis nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo consequat.

library(ggplot?)
tea <- rnorm(100)
biscuits <- tea + rpnorm(100, 0, 1.3)
data <- data.frame(tea, biscuits)
p <- ggplot(data, aes(x = tea, y = biscuits)) +
geom_point() +
geom_smooth(method = "1m") +
labs(x = "Tea", y = "Biscuits") + theme_bw()
print(p)

Duis aute irure dolor in reprehenderit in voluptate velit esse
¢illum dolore eu fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt in culpa qui officia
deserunt mollit anim id est laborum.

1. Lorem Ipsum

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do
eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut

Biscuits

Duis aute irure dolor in reprehenderit in voluptate velit esse cillum
dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non



Quarto document

title: "Covid Cases"
author: "Kieran Healy"
format: html

o rd
#| label: setup
#| echo:

#| message:

# Don't include code chunks in the document
knitr ::opts_chunk$set (echo = )

library(tidyverse)
library(covdata)

EUENEN

## Introduction
We will look at some data from the “covdata® package.

o ri
#| label: data

covnat_daily P
filter (iso3 %in% c("USA", "GBR", "FRA")) D
group_by(cname) [
summarize(cases = sum(cases)) [
knitr :: kable()

LSRN

14

14



title: "Covid Cases"
author: "Kieran Healy"
format: html

i}
#| label: setup

Chunks can have #| echo:
labels or options #| message:

‘ Header section with metadata

# Don't include code chunks in the document

knitr::opts_chunk$set (echo

library(tidyverse)
library(covdata)

Text with ## Introduction
markdown »

= )

We will look at some data from the ‘covdata® package.

IlGBRIII IIFRA")) D

formatting
o rd
#| label: data
When covnat_daily [
rendered, code filter (iso3 %in% c("USA",
chunks are group_by (cname) >
Il;eplacedby summarize(cases = sum(cases)) D
their output knitr :: kable ()

Quarto document annotated

Code chunk
(or cell)

Code chunks can be
“played” one at a time



# Report notes.qmd

We can see this xrelationship*
in a scatterplot.

“““{r my-code}
p <- ggplot(data, mapping)
p + geom_point()

ANAWAY

As you can see, this plot
looks pretty nice.

Render

Report notes.html

We can see this relationship
in a scatterplot.

As you can see, this plot
looks pretty nice.

notes.docx

We can see this relationship
in a scatterplot.

Report

As you can see, this plot
looks pretty nice.

notes.pdf

We can see this relationship
in a scatterplot.

Report

As you can see, this plot
looks pretty nice.

This approach has its limitations, but it’s very useful and has many benefits.




Strengths and weaknesses

Notebooks work
smoothly when

Your document or report is small and
self-contained.

Your analysis is quick or lightweight.
You are making slides.

You are making a lot of similar
reports from a template.

You reqularly refer to calculated
items in the text of your analysis.



Sidenote: In Practice

Even when things get complicated, notebook-style documents like Quarto files
are great as component parts of larger projects. The more complex your project,
the less likely it will straightforwardly fit into a single notebook. The same is
true of script-based approaches. The more complex a project, the more you will
break it up into smaller, more tractable pieces. You will re-factor it, as
programmers say, and make it more modular.

You may find yourself, for example, splitting parts of a complex document up
into different pieces. The pieces will contain code that cleans and pre-processes
data, runs analyses, and produces some outputs. You can then incorporate those
into a Quarto document indirectly. Not by copying and pasting them, but by

pointing to those outputs and making use of them to make your tables and
figures, and so on.



Basic markdown summary

Desired style Use the following Markdown annotation

Heading 1 # Heading 1

Heading 2 #t Heading 2

Heading 3 ## Heading 3 (Actual heading styles will vary.)
Paragraph Just start typing

Bold **Bold**

Italic *Italic*

Images [Alternate text for image] (path/image.jpg)
Hyperlinks [Link text] (https://ww.visualizingsociety.com/)
Unordered Lists

- First - First

- Second. - Second

- Third - Third

Ordered Lists

1. First 1. First

2. Second. 2. Second

3. Third 3. Third

Footnote.! Footnote[”"notelabel]

1The note’s content. [“notelabel] The note's content.


https://www.visualizingsociety.com/

The right frame of mind

This is like learning how to drive a car, or how to cook in a kitchen... or
learning to speak a language.

After some orientation to what’s where, you will learn best by doing.

Software is a pain, but you won’t crash the car or burn your house down.



Create a new Quarto Project

File > New Project > New Directory > Quarto Project
Choose a location for a folder named mptc

Initialize a git repository

Check the “Open in new session” box

Click “Create Project”



Create a new Quarto Document

Once the project opens, create a new file (File > New File > Quarto Document)
Choose “Document” and “HTML” as the output format

Save the file as scratch.gmd in the mptc folder



For now

Get used to editing text files in RStudio and rendering them to HTML or PDF.

Don’t worry about writing any code at this point. Treat it as a way to take
notes for the class.

In the same way that you should be reading around and beyond the assigned
readings for other classes, you should also be exploring R and RStudio on your
own. Try to do things; see what happens.



